Saturday, 11 August 2012 14:02

AppServ Web Server

Before reading this article, you may want to know EasyPHP web server that I setup previously, please refer this page http://diy2u.weebly.com/1/post/2012/07/winxp-easyphp-web-server.html.

 
I'm installing Apserv web server today (11/08/12) due to EasyPHP web server did not display any image slide from my computer.
 
I tested 4 different versions of EasyPHP from EasyPHP-5.3.9 to the latest EASYPHP 12.0, and also tested with different browsers, but I had no luck to make it work. 
 
I confirmed that it is not the Joomla problem, because the same webpages can run on my website (the webpages that you are seeing now). I suspected it must be something wrong with the library settings or the EasyPHP configuration, but I don't want to spend too much of time to figure it out.
 
 
Download
I downloaded AppServ 2.5.10:  http://prdownloads.sourceforge.net/appserv/appserv-win32-2.5.10.exe?download
 
 
Installation
  • Run the downloded file appserv-win32-2.5.10.exe 
  • Desination Folder can be any folder. I'm using d:\AppServ
  • select all AppServ Package Components
  • Server Name: localhost
  • Email address: This email address is being protected from spambots. You need JavaScript enabled to view it.
  • Leave the port to 80
  • Enter root password and Re-enter root password
  • Click Install button to start installation
  • Restart the computer after finish installation
 
Some applications such as PHPadmin also install in the www folder during the AppServ installation. You can delete it if you don't need it. I suggest to keep intact since you might need  it for your databases configuration.
 
Now you can test your webpages by copying them to the www folder. I copy webpages to d:\AppServ\www since the AppServ is installing in D: drive.
 
 
Testing webpages
http://localhost
 
 
Finally I install Joomla & image slide extension. Wow it is working.
 
Unfortunately the PHP version of AppServ 2.5.10 is rather old, it is php 5.2.6. I had no way to restore to my website. I will test AppServ 2.6.0 in the future to see whether it can run on my website.
 
Edited on 13 Sep 2012
AppSErv 2.6.0 is not working in my computer. I'm using Softaculous AMPPS now.
 

 

Read 13415 times Last modified on Monday, 07 October 2013 23:04

Leave a comment

Back to Top